$re = '/(?<![A-Z0-9])[A-Z0-9]{7}(?![A-Z0-9])/m';
$str = 'LTE_LTE_FSD9167__P_Airport1
RUR1251__S_KhooNaiWala';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);