re = /(?<![A-Z0-9])[A-Z0-9]{7}(?![A-Z0-9])/m
str = 'LTE_LTE_FSD9167__P_Airport1
RUR1251__S_KhooNaiWala'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end