using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"string(?:.+?(?=\x3a|%3a))(?:\x3a|%3a)";
string input = @"string:string2:string3
stringAAA:string:str3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}