re = /string(?:.+?(?=\x3a|%3a))(?:\x3a|%3a)/m
str = 'string:string2:string3
stringAAA:string:str3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end