$re = '/string(?:.+?(?=\x3a|%3a))(?:\x3a|%3a)/m';
$str = 'string:string2:string3
stringAAA:string:str3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);