package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bhere\d+?\b`)
var str = `123 here12K there34 bla
123 here12K here34 bla
123 here12 here34k bla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}