const regex = /\bhere\d+?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bhere\\d+?\\b', 'gm')
const str = `123 here12K there34 bla
123 here12K here34 bla
123 here12 here34k bla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}