$re = '/\bhere\d+?\b/m';
$str = '123 here12K there34 bla
123 here12K here34 bla
123 here12 here34k bla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);