import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^()\\n]+";
final String string = "Auburn (Auburn University)[1]\n"
+ "Florence (University of North Alabama)\n"
+ "Jacksonville (Jacksonville State University)[2]\n"
+ "Livingston (University of West Alabama)[2]\n"
+ "Montevallo (University of Montevallo)[2]\n"
+ "Troy (Troy University)[2]\n"
+ "Tuscaloosa (University of Alabama, Stillman College, Shelton State)[3][4]\n"
+ "Tuskegee (Tuskegee University)[5]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}