import re
regex = re.compile(r"""
^[^()\n]+
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("Auburn (Auburn University)[1]\n"
"Florence (University of North Alabama)\n"
"Jacksonville (Jacksonville State University)[2]\n"
"Livingston (University of West Alabama)[2]\n"
"Montevallo (University of Montevallo)[2]\n"
"Troy (Troy University)[2]\n"
"Tuscaloosa (University of Alabama, Stillman College, Shelton State)[3][4]\n"
"Tuskegee (Tuskegee University)[5]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")