using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\""(.*?)[^,]"")";
string input = @"\""TeamName\"",\""PlayerName\"",\""Position\"" \""Chargers\"",\""Philip Rivers\"",\""QB\"" \""Colts\"",\""Peyton Manning\"",\""QB\"" \""Patriots\"",\""Tom Brady\"",\""QB\""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}