re = /(\"(.*?)[^,]")/m
str = '\\"TeamName\\",\\"PlayerName\\",\\"Position\\" \\"Chargers\\",\\"Philip Rivers\\",\\"QB\\" \\"Colts\\",\\"Peyton Manning\\",\\"QB\\" \\"Patriots\\",\\"Tom Brady\\",\\"QB\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end