package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\"(.*?)[^,]")`)
var str = `\"TeamName\",\"PlayerName\",\"Position\" \"Chargers\",\"Philip Rivers\",\"QB\" \"Colts\",\"Peyton Manning\",\"QB\" \"Patriots\",\"Tom Brady\",\"QB\"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}