package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\D+)(\d+)`)
var str = `S31
S4
S2M1L10XL8
S1M2L0XL0
S0M5L6XL8
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}