$re = '/(\D+)(\d+)/m';
$str = 'S31
S4
S2M1L10XL8
S1M2L0XL0
S0M5L6XL8
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);