import re
regex = re.compile(r"(\D+)(\d+)", flags=re.MULTILINE)
test_str = ("S31\n"
"S4\n"
"S2M1L10XL8\n"
"S1M2L0XL0\n"
"S0M5L6XL8\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")