using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Cookie\s([^<>]+?)\sfor\s\.nseindia\.com";
string input = @" <Cookie AKA_A2=A for .nseindia.com/>, <Cookie RT=""sl=3&ss=kkbfh0dv&tt=38z&z=1&dm=>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}