$re = '/<Cookie\s([^<>]+?)\sfor\s\.nseindia\.com/m';
$str = ' <Cookie AKA_A2=A for .nseindia.com/>, <Cookie RT="sl=3&ss=kkbfh0dv&tt=38z&z=1&dm=>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);