re = /<Cookie\s([^<>]+?)\sfor\s\.nseindia\.com/m
str = ' <Cookie AKA_A2=A for .nseindia.com/>, <Cookie RT="sl=3&ss=kkbfh0dv&tt=38z&z=1&dm=>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end