#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Time_in_seconds\[\d+\]Time_in_seconds$\R?"
Local $sString = "Time_in_seconds[1]Time_in_seconds" & @CRLF & _
"Time_in_seconds[123]Time_in_seconds" & @CRLF & _
"Time_in_seconds[*]Time_in_seconds" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")