import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Time_in_seconds\\[\\d+\\]Time_in_seconds$\\R?";
final String string = "Time_in_seconds[1]Time_in_seconds\n"
+ "Time_in_seconds[123]Time_in_seconds\n"
+ "Time_in_seconds[*]Time_in_seconds\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}