re = /^Time_in_seconds\[\d+\]Time_in_seconds$\R?/m
str = 'Time_in_seconds[1]Time_in_seconds
Time_in_seconds[123]Time_in_seconds
Time_in_seconds[*]Time_in_seconds
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end