#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^(<abc>)|\G(?!^))(\S+)[ \t]*"
Local $sString = "<abc>this is between abc</abc>" & @CRLF & _
"<efg>this is between efg</efg>" & @CRLF & _
"<abc>this is between abc</abc>" & @CRLF & _
"<efg>this is between efg</efg>"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)