use strict;
my $str = '<abc>this is between abc</abc>
<efg>this is between efg</efg>
<abc>this is between abc</abc>
<efg>this is between efg</efg>';
my $regex = qr/(?:^(<abc>)|\G(?!^))(\S+)[ \t]*/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";