import re
regex = re.compile(r"(?:^(<abc>)|\G(?!^))(\S+)[ \t]*", flags=re.MULTILINE)
test_str = ("<abc>this is between abc</abc>\n"
"<efg>this is between efg</efg>\n"
"<abc>this is between abc</abc>\n"
"<efg>this is between efg</efg>")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)