use strict;
my $str = '\'source/108_cash_total/\',
\'source/108_customer/\',
\'source/108_daily_units_total/\',
\'source/108_discounts/\',
\'source/108_employee/\',
\'source/56_cash_total/\',
\'source/56_customer/\',
\'source/56_daily_units_total/\',
\'source/56_discounts/\',
\'source/56_employee/\']';
my $regex = qr/\d+_([^/]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}