re = /\d+_([^\/]+)/m
str = '\'source/108_cash_total/\',
\'source/108_customer/\',
\'source/108_daily_units_total/\',
\'source/108_discounts/\',
\'source/108_employee/\',
\'source/56_cash_total/\',
\'source/56_customer/\',
\'source/56_daily_units_total/\',
\'source/56_discounts/\',
\'source/56_employee/\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end