import re
regex = re.compile(r"\d+_([^/]+)", flags=re.MULTILINE)
test_str = ("'source/108_cash_total/',\n"
" 'source/108_customer/',\n"
" 'source/108_daily_units_total/',\n"
" 'source/108_discounts/',\n"
" 'source/108_employee/',\n"
"'source/56_cash_total/',\n"
" 'source/56_customer/',\n"
" 'source/56_daily_units_total/',\n"
" 'source/56_discounts/',\n"
" 'source/56_employee/']")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")