using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<i class=""fa[sb] fa-([\w\-]*)""(><\/i>|\s?\/>)";
string input = @"<i class=""fas fa-disease""></i>
<i class=""fas fa-disease-ball-asdl""/>
<i class=""fas fa-disease-ball-alt""/>
<i class=""fas fa-disease"" /> ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}