import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<i class=\"fa[sb] fa-([\\w\\-]*)\"(><\\/i>|\\s?\\/>)";
final String string = "<i class=\"fas fa-disease\"></i>\n"
+ "<i class=\"fas fa-disease-ball-asdl\"/>\n"
+ "<i class=\"fas fa-disease-ball-alt\"/>\n"
+ "<i class=\"fas fa-disease\" /> ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}