package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<i class="fa[sb] fa-([\w\-]*)"(><\/i>|\s?\/>)`)
var str = `<i class="fas fa-disease"></i>
<i class="fas fa-disease-ball-asdl"/>
<i class="fas fa-disease-ball-alt"/>
<i class="fas fa-disease" /> `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}