#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=_)(?:(?:no)?Wax(?:(?:Only|\d+)?(?=_)|\-\d+(?=-)))"
Local $sString = "Loc3_341001_WaxOnly_S212" & @CRLF & _
"Loc4_34412-a_Wax4_S231" & @CRLF & _
"Loc3a_231121-a_Wax-4-S451" & @CRLF & _
"Loc3_34112_noWax_S311" & @CRLF & _
"Loc3_34112_Wax_S311" & @CRLF & _
"Loc3_34112_Was_S311" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")