use strict;
my $str = 'Loc3_341001_WaxOnly_S212
Loc4_34412-a_Wax4_S231
Loc3a_231121-a_Wax-4-S451
Loc3_34112_noWax_S311
Loc3_34112_Wax_S311
Loc3_34112_Was_S311
';
my $regex = qr/(?<=_)(?:(?:no)?Wax(?:(?:Only|\d+)?(?=_)|\-\d+(?=-)))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}