$re = '/(?<=_)(?:(?:no)?Wax(?:(?:Only|\d+)?(?=_)|\-\d+(?=-)))/m';
$str = 'Loc3_341001_WaxOnly_S212
Loc4_34412-a_Wax4_S231
Loc3a_231121-a_Wax-4-S451
Loc3_34112_noWax_S311
Loc3_34112_Wax_S311
Loc3_34112_Was_S311
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);