package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([aA-zZ]{1,3}\s*[0-9]{1,2}\s*\,*[0-9]{4}\s*)([0-9]{2}:[0-9]{2}):([0-9]{2})`)
var str = `Dec 4,2020 20:06:23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}