$re = '/([aA-zZ]{1,3}\s*[0-9]{1,2}\s*\,*[0-9]{4}\s*)([0-9]{2}:[0-9]{2}):([0-9]{2})/m';
$str = 'Dec 4,2020 20:06:23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);