const regex = /([aA-zZ]{1,3}\s*[0-9]{1,2}\s*\,*[0-9]{4}\s*)([0-9]{2}:[0-9]{2}):([0-9]{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([aA-zZ]{1,3}\\s*[0-9]{1,2}\\s*\\,*[0-9]{4}\\s*)([0-9]{2}:[0-9]{2}):([0-9]{2})', 'gm')
const str = `Dec 4,2020 20:06:23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}