package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{22}$|^\d{10}\-\d{4}\-\d{4}\-\d{4}$`)
var str = `0002057106-2025-2025-0000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}