$re = '/^\d{22}$|^\d{10}\-\d{4}\-\d{4}\-\d{4}$/m';
$str = '0002057106-2025-2025-0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);