const regex = /^\d{22}$|^\d{10}\-\d{4}\-\d{4}\-\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{22}$|^\\d{10}\\-\\d{4}\\-\\d{4}\\-\\d{4}$', 'gm')
const str = `0002057106-2025-2025-0000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}