import re
regex = re.compile(r"(84)2(38|7|96|54|09|04|91|16|06|75|15|18|7|9|3|56|5|71|74|90|14|9|13|36|6|61|8|63|51|77|0|69|19|73|97|93|4|6|39|5|8|37|59|34|1|60|1|05|70|35|55|08|03|59|76|10|57|11|07|33|99|94)(\d{7,8})", flags=re.MULTILINE)
test_str = ("842926263007\n"
"842866598888\n"
"842072214668\n"
"842586504076\n"
"842736588235\n"
"842286544037\n"
"842466577226\n"
"842866739846\n"
"842156516668\n"
"842222210948\n"
"842106286816\n"
"842626338697\n"
"842086567555\n"
"842066562953\n"
"842606502439\n"
"842746294040\n"
"842462538003\n"
"842396542070\n"
"842422456111\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")