$re = '/(?:\G(?!\A)|My\s+nieces\s+are)\s+(\S+):(\d+)/m';
$str = 'My nieces are Cara:8 Sarah:9 Tara:10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);