re = /(?:\G(?!\A)|My\s+nieces\s+are)\s+(\S+):(\d+)/m
str = 'My nieces are Cara:8 Sarah:9 Tara:10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end