const regex = new RegExp('(?P<country>[A-Za-z ,]+)(?: {0,1})(?=[(])?(?:[(]\\w*[)])?', 'gm')
const str = `New York, US
California, United States of America (USA)
Massachusetts, United States of America(USA)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}