re = /(?P<country>[A-Za-z ,]+)(?: {0,1})(?=[(])?(?:[(]\w*[)])?/m
str = 'New York, US
California, United States of America (USA)
Massachusetts, United States of America(USA)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end