$re = '/(?P<country>[A-Za-z ,]+)(?: {0,1})(?=[(])?(?:[(]\w*[)])?/m';
$str = 'New York, US
California, United States of America (USA)
Massachusetts, United States of America(USA)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);