import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SWITCH\\s*([\\d\\-\\s\\:]*)(?:[\\.\\d\\s\\*\\w\\-\\(\\)]*)GROUP\\s*\\d*\\s(\\w*)";
final String string = "\n"
+ "MSCi MSSBTO01 2019-12-23 11:54:06\n\n"
+ "ALARM HISTORY\n\n\n"
+ " <HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42\n"
+ "*** ALARM CMM-0 1A005-00 KICKER\n"
+ " (2691) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP\n"
+ " 01 0784\n\n"
+ " <HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42\n"
+ "*** ALARM CMM-0 1A005-00 KICKER\n"
+ " (2692) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP\n"
+ " 01 0785\n\n"
+ " <HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42\n"
+ "*** ALARM CMM-0 1A005-00 KICKER\n"
+ " (2693) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP\n"
+ " 01 07AC\n\n"
+ " <HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42\n"
+ "*** ALARM CMM-0 1A005-00 KICKER\n"
+ " (2694) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP\n"
+ " 01 07AD\n\n"
+ " <HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42\n"
+ "*** ALARM CMM-0 1A005-00 KICKER\n"
+ " (2695) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP\n"
+ " 01 07AF\n\n"
+ "END OF ALARM HISTORY\n\n\n"
+ "COMMAND EXECUTED\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}