re = /SWITCH\s*([\d\-\s\:]*)(?:[\.\d\s\*\w\-\(\)]*)GROUP\s*\d*\s(\w*)/m
str = '
MSCi MSSBTO01 2019-12-23 11:54:06
ALARM HISTORY
<HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42
*** ALARM CMM-0 1A005-00 KICKER
(2691) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP
01 0784
<HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42
*** ALARM CMM-0 1A005-00 KICKER
(2692) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP
01 0785
<HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42
*** ALARM CMM-0 1A005-00 KICKER
(2693) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP
01 07AC
<HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42
*** ALARM CMM-0 1A005-00 KICKER
(2694) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP
01 07AD
<HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42
*** ALARM CMM-0 1A005-00 KICKER
(2695) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP
01 07AF
END OF ALARM HISTORY
COMMAND EXECUTED
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end