import re
regex = re.compile(r"SWITCH\s*([\d\-\s\:]*)(?:[\.\d\s\*\w\-\(\)]*)GROUP\s*\d*\s(\w*)", flags=re.MULTILINE)
test_str = ("\n"
"MSCi MSSBTO01 2019-12-23 11:54:06\n\n"
"ALARM HISTORY\n\n\n"
" <HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42\n"
"*** ALARM CMM-0 1A005-00 KICKER\n"
" (2691) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP\n"
" 01 0784\n\n"
" <HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42\n"
"*** ALARM CMM-0 1A005-00 KICKER\n"
" (2692) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP\n"
" 01 0785\n\n"
" <HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42\n"
"*** ALARM CMM-0 1A005-00 KICKER\n"
" (2693) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP\n"
" 01 07AC\n\n"
" <HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42\n"
"*** ALARM CMM-0 1A005-00 KICKER\n"
" (2694) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP\n"
" 01 07AD\n\n"
" <HIST> MSSBTO01 CMM-0 SWITCH 2019-12-23 11:53:20.42\n"
"*** ALARM CMM-0 1A005-00 KICKER\n"
" (2695) 2087 LOW TRAFFIC CAPACITY ON CIRCUIT GROUP\n"
" 01 07AF\n\n"
"END OF ALARM HISTORY\n\n\n"
"COMMAND EXECUTED\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")