package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[^\|]*)\|`)
var str = `usr/bin/pipe|pipe|name|28|-rwxr-xr-x|root:root||46711b361edd4512814d9b367ae765f42a71d729708b3f2e162acb8f64592610|
`
var substitution = "$1###"
fmt.Println(re.ReplaceAllString(str, substitution))
}